Upgrade alpine to 3.8


#1

Hi,

we are using the Docker setup for an on-premise skygear setup and it works fine. But i would recommend to update the base image from alpine:3.7 to alpine:3.8 in the near feature.

Regards,
Adrian


#2

Sure! Just created an issue for that.

Ten


#3

Top :+1:

Regards,
Adrian


#4

Hi,

There is a new problem with this issue since Alpine updated the library “libzmq” to 4.2.5 a few days ago. So when i try to build the dockerfile (we have a custom version, but similar to https://github.com/SkygearIO/skygear-server/blob/master/Dockerfile) i get an error on startup skygear:
“panic: zmq4 was installed with ZeroMQ version 4.2.1, but the application links with version 4.2.5”

It means that Alpine installs 4.2.5 and the golang image has 4.2.1. Would it be possible that you update this dockerfile and rebuild the image?

Thanks and regards,
Adrian


#5

Hi Adrian,

We’re working on it. Let me get back to you soon.

Cheers,
Ten Tang


#6

Hi Adrian,

We’ve just release v1.7.2 to fix the issue. Thanks!

Ten